题目描述

This time let us consider the situation in the movie “Live and Let Die” in which James Bond, the world’s most famous spy, was captured by a group of drug dealers. He was sent to a small piece of land at the center of a lake filled with crocodiles. There he performed the most daring action to escape – he jumped onto the head of the nearest crocodile! Before the animal realized what was happening, James jumped again onto the next big head… Finally he reached the bank before the last crocodile could bite him (actually the stunt man was caught by the big mouth and barely escaped with his extra thick boot).

Assume that the lake is a 100 by 100 square one. Assume that the center of the lake is at (0,0) and the northeast corner at (50,50). The central island is a disk centered at (0,0) with the diameter of 15. A number of crocodiles are in the lake at various positions. Given the coordinates of each crocodile and the distance that James could jump, you must tell him whether or not he can escape.

Input Specification:
Each input file contains one test case. Each case starts with a line containing two positive integers N (≤100), the number of crocodiles, and D, the maximum distance that James could jump. Then N lines follow, each containing the (x,y) location of a crocodile. Note that no two crocodiles are staying at the same position.

Output Specification:
For each test case, print in a line “Yes” if James can escape, or “No” if not.

Sample Input 1:
14 20
25 -15
-25 28
8 49
29 15
-35 -2
5 28
27 -29
-8 -28
-20 -35
-25 -20
-13 29
-30 15
-35 40
12 12
Sample Output 1:
Yes
Sample Input 2:
4 13
-12 12
12 12
-12 -12
12 -12
Sample Output 2:
No

分析

  • 将小岛,鳄鱼和岸都视为图中的结点,然后构建一个该图的邻接矩阵。最后用dfs去走就行了

代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
#include<iostream>
#include<math.h>

using namespace std;

int N, D;
int Graph[150][150] = {0};
int crocodiles[150][2];
int visited[150] = { 0 };

void dfs(int v) {
if (v == N + 1) {
cout << "Yes" << endl;
exit(0);
}
visited[v] = 1;
for (int i = 0; i <= N + 1; i++) {
if (Graph[v][i] && !visited[i]) {
dfs(i);
}
}
}

int main() {
cin >> N >> D;
for (int i = 1; i <= N; i++)
cin >> crocodiles[i][0] >> crocodiles[i][1];
for (int i = 1; i <= N; i++) {
for (int j = i; j <= N; j++) {
if (i != j && D*D >= pow(abs(crocodiles[i][0] - crocodiles[j][0]), 2) + pow(abs(crocodiles[i][1] - crocodiles[j][1]), 2))
Graph[i][j] = Graph[j][i] = 1;
}
if (pow(15 + D, 2) >= pow(abs(crocodiles[i][0]), 2) + pow(abs(crocodiles[i][1]), 2))
Graph[i][0] = Graph[0][i] = 1;
if (D >= 50 - crocodiles[i][0] || D >= 50 - crocodiles[i][1] || D >= abs(-50 - crocodiles[i][0]) || D >= abs(-50 - crocodiles[i][1]))
Graph[i][N+1] = Graph[N+1][i] = 1;
}
if (D >= 50)
Graph[0][N + 1] = Graph[N + 1][0] = 1;
dfs(0);
cout << "No" << endl;
return 0;
}